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Exercises

Using Cameras

Let’s talk for a minute about what a Renderworks camera is.  In 
real life, you stand in front of a building with your camera, point 
the camera at a building, and then take a photo. You can do 
something similar in Renderworks using the  camera tool: Click 
on the tool to select a camera, place it the scene and then point 
it at the object you’re interested in showing. You can use many 
Renderworks cameras in a scene, each showing a different view 
of the object.

This exercise will use two Renderworks cameras to generate 
views that will be used in the renderings. 

One camera will show an overall view of the building’s front. The 
other camera will be oriented to display the building at an angle, 
and from a closer distance.

Now, where do we put the cameras? In this file, we’ll place the 
cameras in the layer Site with Buildings which is currently the 
active layer, and contains all the objects in the scene; buildings, 
background items, etc. This is where we will place the cameras.

The bottom layer is called Entourage Locations, and is there only 
as a kind of map, to show the spots where we will place the items 
prepared during this tutorial. It’s only there as a convenience, 
and you do not necessarily need such a layer when preparing 
renderings, It’s really just there for this exercise.

So, let’s go ahead and place the cameras. First, we’ll zoom in to 
the area where the cameras will be located. We can see that the 
two camera locations are marked.

Now let’s place the first camera.

-In the Visualization Toolset, select the Renderworks Camera tool.

-With the tool selected, click once in the center of the marker 
called Camera 1. Then drag the cursor in the direction of the 
marker’s arrow to set a direction, and click again to complete the 
action.
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-By the way, the Object Properties dialog box may appear the 
first time you place a camera in a file. If it does appear, just click 
OK for now.

Now that we’ve placed the camera, how do we see what the 
camera sees?

The camera is still selected. So let’s go to the Object Info palette 
(under the Shape tab) and click on the Display Camera View 
button. The scene will immediately switch to a perspective view, 
exactly as seen by the camera.

If you can’t see the perspective view, click on the Fit to Page 
Area button, up in the View bar, to center the view.

Note: the Entourage Locations layer is still visible. Make 
it invisible by changing the Layer Options to Active Only: 
View>Layer Options>Active Only.

Let’s make an adjustment to the camera. We’ll adjust the 
camera’s height. 

-In the Object Info palette, click on the Fine Tune Camera View 
button. The Perspective View Controls dialog box opens. The 
first slider at the top is the Camera Height control. In the white 
data field, enter the height: 6’-0” [1830mm].

Now the camera is at the desired height, but it is tilting down 
slightly. To correct this, go to the Look To Height slider, and in 
the white data box enter the same height we entered previously: 

1830mm. Click OK.

Now the camera’s actual height, and the direction in which 
it looks are both exactly  the same, so the camera’s view is 
perfectly horizontal.

By the way, the Perspective View Controls dialog box contains 
a large number of camera controls, and these allow you to 
modify the camera’s settings with very fine measurements, to 
suit your exact needs. Play with some of these, either by entering 
dimensions or moving the sliders, to see what changing these 
sliders actually does.

You may find the image on the screen to be be too small. To fix 
this, go to the Object Info palette, and then to the Crop Frame 
Scale Percent databox and enter 200. Basically we’ll double the 
size of the image on the screen.  Notice that the image still does 
not reflect the new crop frame size. For that, we need to update 
the view: still in the Object Info palette, click on the Display 
Camera View button and the image on the drawing will respond 
immediately.. 

One more item, before we place the second camera. Notice 
that there is a frame around the perspective view. This frame 
represents the boundaries of the image that is generated by the 
camera, and its size and proportion can be controlled via the 
Perspective View Controls dialog box (which, as you remember, 
we access by pressing the Fine Tune Camera Button in the 
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Object Info palette. This frame, called the Crop Frame, is useful 
when preparing images for a presentation, because you can see, 
and work with, the outer frame of the image. But if you are in the 
process of developing a model, rather than a final presentation, 
it might be better to not have a frame around the image; this 
way you can work more freely and see more of the model as it is 
rotated and moved around the screen. Basically you have more 
room to work on the model and move around the file without the 
frame present.

To remove the Crop Frame, go to View>Perspective>Cropped. 
Clicking on the word Cropped will toggle the crop frame on and 
off.

Note that a number of operations behave differently with the crop 
frame present or removed. For example, with the crop frame 
removed, using the Pan tool will change the viewpoint shown 
on the screen. But you can always restore the camera’s view by 
switching to Top/Plan view, toggling the perspective crop back 
on.... and then double-clicking on the camera. There are other 
ways of doing this, which we’ll discuss later.

To center the image on the screen, select the Auto Center 3D View 
checkbox.

Now we will place the second camera.

-Switch to Top/Plan view and zoom in again to the area shown 
earlier. Notice the location of the marker called Camera 2. In the 
Visualization palette, select the Renderworks Camera tool, and 
then click to place a new camera in the center of the Camera 
2 marker. Point, move the cursor, and click to finish as we 
discussed earlier.

Note: The Object Properties dialog box didn’t open this time; it only 
opens the first time the Renderworks Camera tool is used in a file.

Now that we have both cameras placed in the scene, how can we 
store, and then retrieve the views these cameras generate? 
Vectorworks provides a number of different ways to do this.

First, you can double-click directly on a camera object. To see 
how this works, let’s double-click on one of the cameras. If 
necessary, click on the Fit to Page Area button, up in the View 
bar, to center the view.

Second, you can find the camera in the Visualization Palette, 
under the Cameras tab, and then double-click on it to see the 
camera’s view.

Once you have the camera’s view on the screen, you can save 
it as a Saved View, for later retrieval.  Click on the Saved Views 
drop-down box in the View Bar, and drag the cursor to Saved 
View. In the Save View dialog box, give the view a name, and 
then click OK. To retrieve this view in the future, go to the Saved 
Views drop-down box and select the view you just saved.

You can also create a sheet layer viewport that shows the 
camera’s view.  With the camera’s view on the screen, go to 
View>Create Viewport. You’ll be asked if you want to link the 
camera to the viewport. We’ll discuss this in a moment, but for 
now Click no.  

The Create Viewport dialog box is now open. Complete making 
your desired adjustments (such as Create on Layer) and then 
click OK.  The viewport now shows the camera’s view. Even if 
you go back to the design layer now, and change the camera’s 
position or settings, the viewport you just created will retain its 
original view.

You can also create a viewport that has a camera linked to it 
directly. Let’s go back to the design layer containing the camera 
view.

Create a viewport (View>Create Viewport). This time, when 
asked if you want to link the camera to the viewport, select Yes.

Now the camera object will essentially become part of the 
viewport you’re creating. To change the camera settings, you’ll 
need to edit the viewport in the sheet layer first. Double-click on 
the viewport, and in the dialog that opens, click on Camera. Now 
you can change the settings via the Object Info palette, as we’ve 
done before, and then click on the Return to Viewport button to 
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complete.

The good thing is that, in this case,  the camera will forever be 
linked to the viewport, so you could control the camera directly 
from the viewport, instead of going back to the design layer and 
making changes (or accessing the camera via the Visualization 
palette) and then creating a new viewport. But it’s important to 
know that the camera object itself will disappear from view in the 
design layer; you will only be able to modify its settings by editing 
the viewport.

So now we’re done placing the cameras in the scene. To finish up 
before moving on to the next task, make the Entourage Locations 
layer invisible by changing the layer options. This way you can 
be sure the information on that layer won’t appear on the final 
renderings.

Exterior Lighting and Renderworks 
Styles

Exterior lighting in Renderworks is actually very simple to do. 
Once you have your model and cameras ready, all you need 
to do is add a sun for sunlight, and then apply a Renderworks 
Style. Why a Renderworks style? Because a style is actually a 
pre-made, one-step combo of settings that supply reflective light 
from the sky, a background image of the sky, and a number of 
other lighting and rendering quality settings, all of them rolled into 
a single command.

Now, exterior lighting in Renderworks typically has two sources. 
One is light from the sun, as I mentioned, and we can place this 
light in a scene using the Heliodon tool, which we’ll discuss in 
a moment. And the other source of light comes from the sky; 
actually from the sky-dome. In Renderworks, light from the sky 
is placed in a scene using a  special kind of light-emitting layer 
background. This kind of sky-light is included in all the Realistic 
Renderworks styles, so once you select one of these Styles, the 
lighting from the sky is automatically included in the lighting set-
up for the file, without needing any further adjustments, in most 
cases.

Let’s take a look at how each of these light sources are placed in 
a file. First, we’ll place a sun.

Make sure the file is open, and in Top/Plan view. 

Now go to the Visualization toolset, click on the Heliodon 
tool, and then double-click anywhere in the drawing to place a 
Heliodon object, which represents the sun. 

It doesn’t really matter where the Heliodon tool is placed, but 
generally it’s better to place it near the center of the drawing.

Now let’s make some adjustments. With the Heliodon object still 
selected, go to the Object Info palette, and notice that you can 
adjust a number of settings directly within the palette. For 
example, click on the Month drop-down box and then select 
September. And now click in the Time data field and enter 3pm. 
Right away you can see the changes in the Heliodon icon, over 
here.

By the way, we can make changes to the settings in two other 
locations as well. First, in the Object Info palette, click on the 
Settings button. The Settings dialog box lets you adjust a 
number of different settings, as you can see here. You can 
choose your project’s region and city, or you can manually enter 
the coordinates of a city you designate. Click OK to finish.

You can also control certain settings in the Solar Animation 
dialog box. Double-click on the Heliodon icon (or edit the 
Heliodon object via the visualization palette, like this.)

Many of these controls are actually intended for the solar 
animation function, which is actually outside the scope of this 
getting-started intro guide. But still, you see how you can easily 
make many adjustments to the sun using these interactive 
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controls. Just make sure the Heliodon setting is selected at the 
top of the dialog box.

Sometimes it’s better to change the settings in the  Solar 
Animation dialog box while you’re in a rendered view, because 
then you can see the results right away, especially when 
rendering in OpenGL. So let’s switch to a perspective view...and 
now let’s render. 

Now we can go to the Visualization palette and edit the Heliodon 
object, and as we change the settings, you can see the results.

By the way, notice that light object icon, where you placed the 
Heliodon? It’s there because of a Vectorworks preferences 
setting, and you can make this icon disappear. Up in the menu 
bar, go to Vectorworks>Preferences. In the Vectorworks 
Preferences dialog box, click on the Display tab at the top, and 
then click on the Display Light Objects drop-down box on the 
right, and select: Only in wireframe. And this way you can see 
the light objects (not just the sun, but all light objects) when in 
wireframe view, but not in the final renderings.

And now let’s complete the exterior lighting for this model. We will 
select a Renderworks Style, which--as I mentioned earlier--is a 
pre-made combo of Renderworks settings that provide a number 
of things--reflective light from the sky,  a graphic background 
image of the sky, and and also pre-made settings for lighting, 
rendering type and quality--all with a single command.for this 
exercise we’ll use the View menu. [View>Renderworks Style...]

Go to Renderworks Style and select Realistic Exterior Final. Even 
though we have not yet applied textures to walls, windows and 
objects, you can immediately see the improved quality of the 
colors, the sky background, and the light bouncing between 
surfaces. 

For a quicker rendering, although a somewhat lower-quality one, 
select Realistic Exterior Fast. The increased rendering speed 
makes it easier to use when working on the model.

Now, as mentioned earlier, all of the Renderworks settings that 
make up a Renderworks Style can be adjusted manually as well. 
If you go to the Resource Browser, for example,  you’ll find the 
Renderworks Styles there, under Render Styles. Right-click on 
one of them, and then select Edit to see the different settings it 
controls. 

Even though they are highly automated, these tools are actually 
very sophisticated as well. For example, see what happens when 
you change the settings for the Heliodon from morning to 
evening. First, let’s render in Fast Renderworks to see things 
better. Now let’s go the Heliodon’s Object Info palette, and 
change the month to August, and the time to 6pm. Notice how not 
only the color of the light has changed--but also the appearance 
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of the sky. 

By the way, this only happens when the Physical Sky and 
Physical Sun checkboxes are selected, in the Heliodon’s Object 
Info palette.

All of these settings are described in other support materials 
provided by Nemetschek, both in the Help resources, and in 
detailed training manuals. But the main thing to keep in mind, is 
that most exterior renderings may not require many adjustments. 
In most cases, all you need to do is place a Heliodon object in 
the scene, and then select a Renderworks Style, and you’ll get a 
good quality exterior rendering.

One of the things that can really enhance the appearance of 
a rendered scene, is the application of textures to walls and 
objects. And that is the topic of our next task.

Image-Based Textures

You can think of Renderworks textures as images that are 
wrapped around objects, like decals, tightly attached to the 
surfaces of those objects. In actuality they’re more complicated 
than that, because, depending on the method with which they’re 
attached and then adjusted in their location, also called texture 
mapping, they can not only be attached to the surface of objects, 
but actually go through those objects, so that if you were to cut 
them open you could see the textures go all the way through.

These textures can have all kinds of special attributes. They can 
be opaque, they can give the appearance of having some three-
dimensionality to them, they can be made transparent, they can 
be made to be shiny or reflective--they can have many different 
features.  But at the core, they are essentially images wrapped 
onto objects.

Now, we’re going to look at three types of textures, and different 
ways of applying them to objects. One of these textures is 
already included in the exercise file, and we’ll apply it to a few 
simple extruded objects.     Another texture is based on a graphic 
image of travertine stone that we will import into the file,  convert 
it to a texture, and then apply it to walls in our model.      And then 
we’ll create the third texture completely within Vectorworks, using 
built-in tools that come with Renderworks, and without importing 
any graphic images from the outside. This particular texture will 
be both transparent and shiny, and will represent glass in the 
model’s doors and windows.

Let’s open the file for this task, building-new-textures.vwx. It’s a 
modified version of the file that we used for previous tasks, and 
has a few textures already applied.

So, first switch to Right Isometric view. Let’s zoom in a little. And 
now render in OpenGL.     By the way, to render a scene you can 
use a menu command, as we’ve been using, but you can also 
use the Render button up in the View bar, like this.

Let’s look at the OpenGL rendering.  You can see some green-
colored objects in the scene, over here. 
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These are simple extruded shapes that represent landscaped 
areas with grass, so we’ll apply a grass texture to those objects. 
The texture is already in the file and can be found in the 
Resource Browser, here.

Select one of the green objects. And now in the Object Info 
palette, click on the Render tab, at the top.    This is the place in 
the Object Info palette where you can apply textures and control 
their appearance on the object. Go down to Texture, click on the 
drop-down box, and then choose the texture we’ll use, Grass.        

See how the texture is immediately evident on the 3-D object we 
selected. By the way, when you click on the Texture drop-down 
box, you can see the textures that come already installed with 
Renderworks, and select from the list if you need one. Your own 
list, incidentally, might appear a little different than this one.

One other thing, if you click on the Part drop-down box, here,    
you’ll see that for this kind of extruded object you can actually 
apply the texture to specific faces of the object, if that’s what you 
want. You can select the surface that will receive the texture. And 
you can even apply different textures to different faces, by 
selecting a specific face, and then choosing a texture. But for this 
exercise,  let’s leave this in Overall for now. 

Let’s apply this texture to the other green objects. We’ll use the 
Eyedropper tool. In the Basic toolset, which is this one, select the 
eyedropper tool. 

And now press the Preferences button in the Tool bar. And then 
select the desired setting that you want to transfer from the first 
object that we completed, to the rest. In this case, we’re 
transferring the fill attribute: Texture.

Click on the surface that we’ve already textured, to “pick up” the 
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texture, and in the Tool bar click on the bucket icon, and then 
click on the next object--make sure it highlights, first--, in order to 
“pour” the texture into it. You can see the texture once it the file 
has re-rendered. 

And now continue clicking on each of the other objects to apply 
the texture to them as well.   Make sure the cursor is over 
the edge of each object in order to confirm, with the highlight, 
that you’ve selected the right object, before clicking to apply 
the texture. That’s really important, to make sure you haven’t 
selected the wrong object for this texture.

We’re done with the grass texture, and now we’ll create a stone 
texture, and then apply it to the walls of the model. In the 
Resource Browser, click on the Resource Menu button...here...
and select New Resource in Building New Textures (which is the 
name of the file), and then Renderworks Texture. 

Now in the Edit Texture window, let’s give the texture a name: 
Stone. And under Color, select Image.

And now the program asks you whether to import an image file, 
or reuse one that already exists in the file. We’ll be importing 
an image, so select: Import an Image File. And now navigate 
to the place where the image file is located; which is the folder 
containing this Vectorworks exercise file. The image file’s name 
is travertine.png. Select it and then click Open. You’ll see the Edit 
Image Color dialog box; leave things as they are, just click OK.

So now, we’ve created a new texture, we named it, and then we 
imported an image, which is the basis of the texture. Now that 
we’ve done all that, we need to modify the texture a bit, to make 

it the right size. In the Size area, on the bottom right-hand side, 
click on the Set By Image button. In the  Set Image Size window, 
grab the little round handle at the upper left side of the window, 
and then drag it over to the right edge.  That’s our dimensioning 
device. 

Next to Feature Size enter: 3350mm, and then click OK.

By the way, the right side of the Edit Texture dialog box is actually 
the preview for this texture, and you’ll notice it looks blurred. 
That’s because the sample size that is shown in the preview 
window is too small. So next to Object Size, enter 3000mm and 
then hit the Tab button. We’re done making this texture, so press 
the OK button.

Now let’s apply the texture to the building’s walls....or at least to 
some of them, anyway. Let’s zoom in closely to the lower right-
hand corner of the building, so we can see better. Now select the 
main front wall of the building. In the Object Info palette, click on 
the Render tab. 

First thing we’ll do, is select the part of the wall to receive our new 
texture. Click on the Part drop-down box and select Right. Now 
we’ll select a texture: click on the Texture drop-down box and 
select: Stone. Render in OpenGL to see the effect. Now select 
the wall to the right of it, and repeat the process: in the Object 
Info palette, click on the Part drop-down box and select Right. 
And then click on the Texture drop-down box and select: Stone.
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Now, these are unstyled walls, and we’ve applied the texture 
to them manually. There are other methods available, such as 
applying textures to wall styles, to classes, and so on, and these 
are described in the support materials. But the easiest and most 
straightforward way of applying a texture to unstyled walls, is to 
do it manually as I just showed here.

Let me talk for a minute about repetitive textures and the images 
that are used to create them. When you use repetitive textures, 
such as the stone texture we used here, that shows stone blocks 
applied to an entire wall, or--for example--brick textures, the 
actual image that we import doesn’t need to be the full size of 
the entire wall. In our building here, for example, the front wall is 
more than 36 meters long; as you can imagine, that would be a 
huge texture. Instead, the image that we use for such a texture 
actually represents only a small portion of the overall size of the 
wall, and then the texture is repeated multiple times upon the 
surface of the wall, or the object you’re texturing, as if it were a 
tile. And in fact, the process is called tiling.

Let’s take a look at an example. Here’s a building that has a brick 
texture applied, but only a single instance of the image used for 
the texture is shown on each wall. It isn’t tiled, in other words; 
there’s only one tile showing. 

But once the texture is fully tiled, you can see it covering all of the 
walls, without being able to distinguish where one tile ends and 
the next one begins. That’s because the image that is used to 
create the texture has been specially modified, along its edges, to 
repeat seamlessly when it is applied to a surface as a tile. 

This is something you can control via the Object Info palette, by 
selecting the Repeat Horizontally and Repeat Vertically 
checkboxes, near the bottom of the palette. If these items are 
Deselected, you will only see a single instance of the tile. If you 

select these checkboxes, the image tile will be distributed across 
the surface you’re texturing.

Now, if you’d like to create your own images to use as textures 
that you can tile across surfaces, it’s not enough to just run out 
with your camera and photograph a brick wall. You’ll need to 
modify the image properly--and that means straightening out 
lines, correcting lens distortions, and treating the edges for 
seamless repetition. You can do this in Photoshop, and in other 
programs also, but be aware that it can be a great deal of work, 
and not always easy to do. Let me show you what I mean.

Here’s an example of the same building we saw earlier, but with a 
different brick texture. And this texture used an image that was 
developed properly. The texture tiles across the walls nicely, and 
you can’t tell where it ends or starts. 

And here is the same building but with a different texture, this one 
made with an image that didn’t receive the correct treatment.

Now, Renderworks already comes with a large number of 
excellent textures, and there are outside sources for images that 
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can be used for tiling textures as well; some of them are available 
on the internet, for example. But the main thing to keep in mind 
is that the images you use must be modified so that they can tile 
seamlessly, without visible borders. 

Anyway, back to our exercise.    Let’s take a look at the 
appearance of the building in perspective, now. Switch to Saved 
View 1, and render with the Renderworks Style: Realistic Exterior 
Final.    

You can see that the glass in the doors and windows  is opaque 
white, instead of transparent. So our next item is to create a glass 
texture for doors and windows, a texture that will be transparent 
and reflective.      

Procedural Glass Texture
In part 2 of this texturing exercise, we will create a glass texture 
and then apply it to doors and windows.

Go to the Resource Browser, click on the Resource  menu button, 
and then select New Resource in Building-New-Textures, and 
then select Renderworks Textures. In the Edit Texture dialog box, 
give the new texture the name: Glass.

Now, take a look at the left side of the Edit Texture dialog box. 
Each texture is made up of four shader types. These shader 
types are actually individual components that give the texture 
certain features: color, reflectivity, transparency and bump (which 
gives the texture a three-dimensional appearance). Not all 
textures require all four of these shader types, and for this glass 
texture, we’ll only use three: Color, Reflectivity and Transparency. 
Let’s start with Color.

In the Shaders area on the left, click on the Color drop-down box, 
and select Color. And now we need to select a color, so click on 
the Edit button, next to the drop-down box. And select a color 
for the glass. For this exercise, the color should be nearly black, 
but just a little bit lighter, really a very dark grey. The reason for 
this, is that the color black will make the glass almost completely 
transparent in the rendering, very clear and clean-looking. But 
adding a little bit of white will make the glass just slightly opaque, 
to make the window stand out a bit in the rendering. So select a 
dark grey, and after selecting the color, click OK.

Now let’s make the glass reflective. We do that by choosing a 
Reflectivity shader. Click on the Reflectivity drop-down box, and 
select Glass, which is one of the reflectivity shaders. Now click 
on the Edit button next to the Glass shader’s drop-down box, 
and select a Center Color, which will give the glass a slight tint of 
color when viewed from certain angles. Select a very dark green, 
like this one.... but not too dark, otherwise it will just look grey in 
the rendering. After selecting the color click OK.

And finally we need to make the glass transparent. Click on the 
Transparency drop-down box and select Glass, which is one 
of the different transparency shaders available. Now click on 
the Edit button next to the Transparency shader’s drop-down 
box, and this is where you can adjust a number of the glass 
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transparency’s features. In this case we’re increasing the amount 
of light that can pass through the glass, that is, making it a little 
more transparent than the default. So in the Transmission data 
field, enter 90. 

You can see that there is a certain pattern to creating these 
textures using the built-in tools provided by Renderworks. 
Basically each texture can be composed of up to four shader 
types. Select the shader types that are appropriate for the 
texture, and then click on the shader type’s edit button to make 
adjustments. It’s worth experimenting with the different shaders 
that you can find under shader types, because sometimes the 
one you need may not be immediately evident. For example, in 
some cases when creating a glass texture with Reflectivity, it is 
better to choose the Mirror shader, instead of the Glass shader 
for that shader type.

Now click OK to finish, and we’re done with the glass texture. 
There’s one last thing we need to do with the glass texture, and 
that is apply it to the doors and windows.

In this file, all the doors and windows have been set up to have 
the glass placed in a separate class called  Glazing-Clear. Let’s 
take a look at this.  Switch to Top/Plan view, and then zoom in 
and click on the entry door. 

In the Object Info palette, under the Shape tab, click on the 
Settings button, and in the Door Settings dialog box, click on 
Classes, on the left. Now look at the last three items in the 
Classes list, in the center column. You can see that Glazing, 
Sidelight Glazing and Transom Glazing have all been placed in 
the Glazing-Clear class. It’s not just the doors, but the windows in 
this model have also been set up in a similar way.

Why is this important? Because in Vectorworks, it’s possible 
to assign a particular texture to a specific class, and so when 
you put an object in that class it will automatically display the 
assigned texture as soon as you render. 

In this case, since all the doors and windows have their glazing 
assigned to the Glazing-Clear class, all we need to do is assign 
the new glass texture that we just created, to that class, and then 
all the doors and windows will automatically display the new glass 
texture when we render.

Let’s open the Organization dialog box, and click on the classes 
tab, which is the first on on the top left. You can see the Glazing 
class, so let’s click on the little triangle to open it up....and now 
select Clear, and then click the Edit button at the bottom. So now 
we’re editing this class.

The bottom part of the Edit Classes window is where you assign 
textures to this class. You’ll see three tabs here, where you can 
select walls, roofs or Other.  In this case, the glass in the windows 
are not roofs or walls, so click on Other. Now we need to select 
an assigned texture, so click on the Texture checkbox, and then 
on the selection tool beneath it, and select the texture Glass. 

Click OK to finish, and then click OK again to close the 
Organization dialog box. Now we’re done assigning the glass 
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texture to the Glazing-Clear class, so let’s switch to a perspective 
view and render to see the result.

Now the methods that we’ve used here to apply textures to 
objects, are just a few of the ways that we can apply textures. 
Vectorworks offers many different methods for this, including 
applying textures to specific faces of objects and not others, 
assigning textures to different wall styles, so that when you use 
such a wall style the textures are immediately displayed when 
you render, and there are other methods as well. 

The ones we show here are among the most easy to use, but 
once you become more familiar with Renderworks and begin to 
do more work with it, it’s worth looking up all these other methods 
in the support materials, because if the files are set up to use 
them, they can actually save you a great deal of time and effort.

Mapping Textures
In the last part of this texturing tutorial we’ll discuss three tools 
that are available for adjusting the size and location of textures 
on surfaces.  Until now we’ve just talked about placing textures 
on surfaces. Once you’ve placed a texture, though, you’ll often 
need to adjust it’s position. Renderworks provides a number of 
tools  for adjusting the location of the texture on the surface of 
an object, and also for changing the apparent size of the texture 
as well, beyond the size you specified when the texture was 
originally created.

Let’s take a look at a sample project; this is a similar building to 
one we saw earlier, but with different textures applied. The first 
tool we can use to adjust the texture’s placement on the surface 

of an object is the Object Info palette.

So let’s zoom in, and then  select one wall here, and now take a 
look at the Object Info palette.    Click on the Render tab to 
access the rendering controls, and scroll down to the bottom half 
of the palette, which contains a variety of texture mapping 
controls. Texture mapping refers to the process of placing 
textures on surfaces, and then adjusting their size and location. In 
this tutorial we’re looking at a few specific items.

By the way, when you’re adjusting textures on walls, before 
making any changes in the Object Info palette, make sure that 
the correct wall surface is selected in the Part drop-down box, 
otherwise you may not see any changes taking place. In this 
case, the texture is applied to the Right side of the wall, so I’m 
making sure the Part drop-down box has the Right side selected.

Back to the bottom of the Object Info palette. First, note the two 
Offset data fields. Entering horizontal and vertical dimensions 
here will move the texture in those directions on the surface of 
the object. So in the Offset V data field, V for vertical, I’ll enter 
300mm, and the change is visible right away, since the scene is 
rendered in OpenGL. Sometimes, if the image is broken up a little 
bit, force a redraw by double-clicking on the Pan tool, in the Basic 
palette.

Now there are other controls here that change the position of the 
texture directly. For example, we can change the rotation value, 



16 | Renderworks 2013 Getting Started Guide

either by entering a value in degrees, or moving the slider 
interactively, like this.

And we can also change the size of the texture on the object, by 
changing the Scale value above. You can do this, again, either by 
entering a value in degrees, or moving the slider interactively. 
Moving the slider all the way to the right will double the scale of 
the texture. But you can always enter a larger or smaller number 
manually in the data field, and then press the tab key to see the 
result.

The last item is the Use World Z for Origin checkbox, near the 
very bottom of the palette.

This item helps align textures on different layers. When the walls 
or objects on each layer have this item selected, the textures will 
usually align vertically in a seamless fashion. 

Let’s try it here. First I’ll increase the scale of the second floor 
texture to match the one on the lower floor. And now I’ll select the 
Use World Z for Origin checkbox for each of these walls.

How well they align depends on a number of things, including the 
nature of the texture itself, but when you have a problem making 
sure that objects on different layers have their textures align 
vertically, try selecting the Use World Z for Origin checkbox.

Another tool for aligning and selecting textures is the Attribute 

Mapping Tool. This tool is located in the Basic palette, here....

First, I’ll switch to a Front view, in order to see this more clearly, 
and then render in OpenGL.

Now, the Attribute Mapping Tool lets you manipulate a texture on 
an object’s surface directly. To use this tool, select it in the Basic 
palette, and then click the wall or surface on which the texture is 
located, to select it. You may need to select the Original Repeat 
Mode in the Tool bar, in order to see the entire repeating texture.

Now move the cursor over the surface, and you’ll see a set of 
blue markers, or control handles. Move the cursor over the center 
marker, shaped like a diamond, until the cursor changes into a 
cross. Then you can click and drag the texture into position. You 
can move the texture, and snap to corners or other elements, and 
even rotate the texture on the surface.

Now all of these tools have more capabilities than I’ve shown 
here, and it’s definitely worth experimenting with them to see 
what they offer. What we see in this tutorial are the basic aspects 
of these tools, but much more is available once you become 
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familiar with them, material that is documented in the Help and 
other sources. But the main point is that after you’ve applied a 
texture to a surface, you can adjust its location, and its size, by 
using the Object Info palette’s controls, or the Attribute Mapping 
Tool.

Creating Image Props
If you want to add images of trees, people, cars and other 
accessories to a scene (in architecture this is often called 
Entourage), you have a few options. It’s possible to create or 
import 3-D models of these things, but sometimes these models 
can be so big and complex that they make the file unwieldy to 
use, and slow to render. Here’s a quick example, of a very very 
simple 3-D model of bamboo, originally  a Sketchup model, that 
has over 12,000 separate objects and polygons within it. 

You can imagine that a more complex model that requires each 
3-D polygon to be calculated and rendered could add a significant 
burden on the computer’s brainpower, and this can actually slow 
things down quite a bit, depending on the computer’s power and 
the complexity of the model.

Now with some renderings you really do need complicated 3-D 
entourage. But in other cases, you can take advantage of a 
much faster and simpler technology, called image props. With 
Renderworks, you can create a simple, flat object containing an 
image--or actually a texture--of an entourage item, such as a tree. 
This called an image prop, and it’s a kind of flat billboard that has 
special features that increase the sense of realism. An image 
prop can be a lot simpler than a complicated 3-D model, and it’s 
often a good alternative to complicated entourage.  

Let’s take a look at a specific example. Accompanying this part of 
the tutorial is a file called “image prop example.vwx”. Let’s open 
the file, and you can immediately see, in wireframe view, the 
outline of the flat imageprop, over here. And now render in 
OpenGL. By the way it’s a good idea to set it to the best OpenGL 

rendering quality . Go to View>Rendering>OpenGL Options, 
and make sure the settings are the same as these. Set the Detail 
to Very high, and select Use Textures, Use Anti-Aliasing and 
Use Shadows.

So there are a number of things worth noticing. First is that the 
image has a transparent background, meaning that you can see 
around and in-between the leaves of the tree. Another  is that 
even though the image-prop is flat, and may not be pointing 
toward the viewer when you see it in wireframe view, when the 
image is rendered, it appears oriented properly. You can see it 
here, when we render in wireframe and then in OpenGL. 
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These two features, transparency (also called a transparency 
mask) and the rotation toward the viewer when rendered, are 
basic and important features of image props. The transparency 
capability means that you can create a 3-D appearance very 
simply using flat objects one behind the other so that you 
can see them overlapping, and the rotation toward the viewer 
means that you can place these objects anywhere in the scene 
without worrying about orienting them properly to a specific view, 
because when you render the scene they will always appear 
rotated toward the viewer.

Now, a large number of image props are already provided with 
Renderworks, ready to drop into a scene. All of them have these 
basic features of transparent backgrounds, and rotation toward 
the viewer. In this tutorial we’ll take a look at how you create an 
image prop, and then we’ll switch back to the main model file that 
we’ve been working on until now, and place a variety of image 
props in different locations around the model, to increase its 
realism.

The image prop we’re creating is the one shown in this example. 
So first we’ll need a graphic image file as the basis of the image 
prop. You’ll find it in the folder containing this tutorial, it’s called 
tree five image.png.  And now let’s switch to a Top/Plan view.

The process of making an image prop is a straightforward, step-
by-step procedure, so I’ll just call out the steps one by one.

Step 1: go to the menu command Model>Create Image Prop.

The Choose Prop Image dialog box will open, asking us to 
select an image to be used in the image prop. We’re not re-using 
an image, instead we’ll import one.

Step 2: Click on Import an Image File, and then click OK.

The Import QuickTime Image Document dialog opens.

Step 3: Navigate to the folder containing this exercise. The image 
file to be used for this image prop is located in this folder, and it’s 
called it’s called tree five image.png.

Step 4: Select the image and then click on the Open button.

The Image Prop Options dialog box opens. 

Step 5: In the Name data field, type a new name for

this image prop: tree five.

Step 6-Under Dimensions, change Height to 3660mm, and make 
sure that the Lock Aspect Ratio checkbox is selected. This way 
when you change the height, the image will automatically acquire 
the correct width.

Now we’ll make the background color of the image transparent, 
so that only the image of the tree itself will be seen.

Step 7-Under Mask Options, select Use Mask, and then click on 
the Create Mask button.

The Choose Prop Mask Image dialog box opens. To create 
the transparency mask (required in order to make a portion of 
the image transparent) we’ll reuse the image we have already 
selected:

-Click on Reuse an Image from Another Resource.

-Leave the drop-down box at This Prop’s Color (if that is not the 
default selection, click on the drop-down box and select This 
Prop’s Color).Click OK.

Step 9-In Create Mask dialog box, Select Transparent Color, and 
click OK.

The Create Transparent Color Mask dialog box opens. We will 
now select the color to be used as a transparent color mask 
(anything in that color will be transparent in the image prop). 
Notice  that the original image, which you can see here, has been 
prepared with a uniform background of a single color, because 
when you make an image prop, it is easier to pick out a single 
color and make it transparent.
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Step 10-In the left window, click on the black background color. 
This will make it transparent.

Click OK.

Now we’re back in the Image Prop Options dialog box.

Step 11-Deselect Constant Reflectivity. This setting increases 
(or maintains) the brightness of the image prop, even when it is in 
the shade. We don’t need that for this example.

Step 12-Make sure the Create Symbol checkbox is selected. 
This will make the image prop into a symbol that can you can 
place repeatedly throughout the scene.

And the final step-Make sure the remaining options are as shown 
below. These are: height, Lock Aspect Ratio, Create Plug-in 
Object (this will automatically make the symbol into an image 
prop plug-in object when you place it in the scene); Auto Rotate 
to Viewer and Create Symbol.

Click OK.

And now notice that an image prop has been placed in the center 
of the drawing. It’s flat, so you will only notice  a thin line. But if 
you change to a Right Isometric View you’ll see the outline of the 
image prop. Now switch to Saved View 1, and then render with 

Realistic Exterior Fast.

Now, notice that with the new image prop selected, the Object 
Info palette provides a few controls, such as height, width, and 
other items. You always make some changes top the image prop 
by modifying these settings directly in the Object Info palette, like 
this.

So now we’re done making the image prop, and we can copy 
and then paste it into our building file that we’ve been working on 
during this tutorial. So, let’s copy the image prop... and now we’ll 
open the building exercise file. For this part of the tutorial, the 
building exercise file is located in the same folder as the rest of 
the material used here. So open the file building-new-entourage.
vwx. And once the file is open, go to Edit>Paste it in place, like 
this. The image prop will be pasted into the interior of the building, 
but we’ll move it shortly to its correct position.

As you may remember, this exercise file has a layer containing 
a kind of placement map for the different items we’ll be 
placing in the drawing. Let’s make it visible by changing layer 
options and making the other layer visible. Go to View>Layer 
Options>Show/Snap Others.

Notice in the front center of the building a label called New Image 
Prop. Grab the image prop we just created and move it over to 
the label location. 

And now all that remains is to go to the Resource Browser, select 
individual image props that are already included in the file, and 

then copy them onto the locations shown in the placement map 
that is visible. 

So let’s go to the Resource Browser, and make sure that the 
browser shows the active file, like this, and double-click on the 
Symbols/plug-in objects folder to expose its contents. And now 
simply drag and drop each image onto the appropriate spot in the 



20 | Renderworks 2013 Getting Started Guide

drawing. We’ll start with the “father and son” imageprop. Select it 
in the resource browser, then drag it over to the drawing and 
place it here. And do the same with each of the remaining image 
props.

The file also includes one 3-D entourage item, a car symbol. Use 
the same process to place it in the scene too. Click to select it in 
the Resource Browser, and then drag and drop it onto the right 
spot.

Once you’re done placing all the image props and entourage 
items, change the layer visibility back, switch to Saved View 2, 
and render with the Realistic Exterior Final renderworks style.      

Export Image
Up to this point, we have prepared a model, applied textures to 
walls and other objects, and then placed entourage in the scene; 
trees, people and a car. Now we can render the scene, and 
after rendering, we can then either print it directly, or export the 
rendering for use with other programs. 

Until now we’ve worked entirely in design layers, but for this 
exercise we’ll be working with a sheet layer viewport showing a 
saved, perspective view. Let’s open the Vectorworks file for this 
exercise, building-new-export image. The file already has a sheet 
layer viewport prepared, and you can find it by going to saved 

view 3.

Now, what you see here is a viewport containing a wireframe 
view of the scene, based on a saved view developed in the 
design layer, earlier. As far as lighting goes, the design layer 
already contains a Heliodon object representing the sun, so we 
only need to render the viewport with a Renderworks Style. A 
render style automatically includes light from the sky, so that’s all 
we need to complete the rendering.

To do that, click on the viewport to select it, and in the Object Info 
palette, click on the Background Render drop-down box, and then 
to Renderworks Style and Realistic Exterior Fast. 

We’re using Realistic Exterior fast here so that we can see the 
rendering quickly, but for the final rendering you can use Realistic 
Exterior Final.

Now, unlike a design layer, a viewport will not start rendering 
automatically as soon as you choose a rendering method. 
Instead, you have to update the viewport to get the rendering 
process started. And you do this by clicking on the Update button 
in the Object Info palette, here.

Now that the viewport has rendered, we’ll export the image as an 
image file that can be used for various purposes, such as a web 
presentation, or printed materials such as brochures, reports or 
simply large rendered images. Now you can export the image 
as a PDF, of course, but in this tutorial we’re focusing on image 
formats such as JPEG and TIFF, which are often used for web 
design and printed presentations.

To export an rendered image, go to File>Export>Export Image 
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File. In the Export Image File dialog box, arrange the settings as 
shown here. Beginning in the upper left side, in the Export Area 
you have several different options, which are pretty much self-
explanatory, but let me focus on two specific options. 

Current View will export the sheet with the rendering exactly 
as shown on the screen, so if you are zoomed out and include 
a lot of empty area around the image, that is exactly what the 
rendering will include. 

Marquee allows you to draw a fence–or marquee–around the 
specific portions of the rendering you want to include in the 
image.

Each Page as Separate Image will export the area within the 
margins, and is most often used when exporting an image from 
a viewport. If you have more than one page set up in your Page 
Setup settings, it will export all the pages (or actually the areas 
within the margins of all the pages) as separate images. For this 
tutorial, we’ll use this selection.

In the Dimensions area, make sure Lock Aspect Ratio is 
selected. This way, if you change the height of the exported 
image, for example, the width will adjust automatically to the 
correct dimension. We’ll come back to Resolution in a minute.

Print size. Once you have selected Each Page as a Separate 
Image, which we talked about a minute ago, you can leave Print 
Size alone, since it will automatically reflect the size of the image, 
which is based on the size of the sheet you’re using. In this case, 
we are using an A4 sheet with margins that are shown in the 
viewport.

Now let’s select the format of the image we are exporting. In the 
Format area, click on the File Type drop-down box and select a 
format.  JPEG and PNG are good for viewing on monitors, or for 
web design. TIFF is a good choice for printing. Photoshop will 
export a file in native Photoshop format.

Once you’re done selecting the export options, click on the Save 
button. The Export as QuickTime Image Document opens, and 
you can select a spot to save your image, and a name for the 
image, and then you can click the Save button to finish exporting.

Let’s go back for a minute to to the Export Image File dialog box. 
File>Export>Export Image File.

Under dimensions, you can see a data field where you can 
change the resolution, when certain formats are selected, such 

as TIFF or JPEG.    Generally, it’s best to have the Resolution 
here, march the resolution of you sheet layer viewport. If your 
sheet layer resolution is at 300dpi, then it’s best to have the 
export image file resolution at 300dpi as well, and the same for 
72dpi, they way we have it  here. They should both match. Now, 
here’s what I mean.

Let’s take a quick close-up look at the viewport rendering, and 
zoom in to see some detail. When you zoom in, to about here, 
you can see that the image is blurry, and some diagonal lines 
actually appear to have steps in them.

That’s because the sheet layer on which the viewport resides is 
currently, and by default, set to a low resolution of 72 dots per 
inch, which is good for viewing on a screen, but really too rough 
for most printing purposes. Printing normally needs a much 
higher resolution in order to preserve the sharpness and quality 
of the printed image. For printing purposes, a resolution of 300 
dots per inch is often a good setting. And here’s a comparison, at 
a different scale so we can see this effect clearly, of this viewport 
at 72 and 300 dpi.

[Now let’s zoom out again. ]

To increase the resolution of the sheet layer, you have to edit 
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the sheet layer, and you can do that in the Organization dialog 
box, or in the Navigation palette, if it was installed with your 
Vectorworks package. Let’s open the Organization dialog box: 
go to Tools>Organization, and then click in the Sheet Layers 
tab at the top of the dialog box.  The “renderings” sheet layer will 
be highlighted, and if not, click to highlight it now. Click on the 
Edit button at the bottom of the window, and in the Edit Sheet 
Layers dialog box, change the DPI setting, from 72 to 300. Click 
OK to close this dialog box, and then click OK again to close the 
Organization dialog box.

So now you can see the candy-stripe indicator around the edge 
of the viewport, here, which means you have to update the 
viewport, since we’ve changed the settings. 

Go to the Object Info palette, and click on the UPdate button. 
The viewport will start re-rendering, but it will render much more 
slowly this time, because it has to calculate and display a much 
larger number of dots on the screen. So just keep in mind, that 
for screen viewing you can use a low DPI figure for the sheet 
layer, such as 72, but for printing you need a higher number, even 
though it takes a lot longer to render.  

OK,  let’s stop the rendering. And let’s change the resolution 
back to 72dpi, for now. Click on the layers button up here to open 
up the Organization dialog box, and then in the Organization 
dialog box, click on the Edit button. In the Edit Sheet Layers 
dialog box, change the DPI back to 72.                                                    

And now let’s update the viewport again in the Object Info palette, 
and once that’s done, we’ll export the image: File>Export Image 
File.

So now under Dimensions, adjust the resolution to match the 
resolution of the sheet layer. If you set the sheet layer to 300 
dpi, for example, set this one here to match. You don’t want the 
sheet layer to be at 300dpi, with all that rendering time involved, 
and then export at only 72dpi and lose all the sharpness that you 
worked so hard to achieve when you increased the resolution of 
the sheet layer.

Once you’re done selecting the export options, click on the Save 
button. The Export as QuickTime Image Document opens, and 
you can select a place to save your image, and a name for the 
image, and then you can click the Save button to finish exporting.

Interior Night Lighting
For interior night-time scenes, you have to insert lights in order 
to illuminate a space, just as you would in real life. Vectorworks 
provides a number of different light types, most of which are 
accessible using the Light tool in the Visualization palette.

Let’s open the file for this exercise: Building Lobby Night.vwx.  
Now let’s switch to Saved View 1 and render with OpenGL.     
You can see that the scene is dark because there are no lights 
placed in the space. So to begin, we will place lights in the room, 
but first we switch to Top/Plan view to see this more clearly.

Let’s place the first light. Go to the Visualization palette and click 
on the light tool. 

And then, up in the Tool bar, select the kind of light you prefer. 
Vectorworks provides a number of different lights here. You can 
select a directional light (equivalent to the sun), a point light (as in 
a bare light bulb) or a spot light (which similar to a flood light or a 
regular spot light, which casts light in a specific direction). 

For this tutorial, we’ll use a point light, so click on the Point Light 
Mode button, in the Tool bar and then click once in the scene, 
over here, to place a light.
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The first time you do this during a Vectorworks session, the Light 
Preferences dialog box will open. You can leave the settings 
as they are, for now. We’ll be adjusting them in the Object Info 
palette. 

As soon as you’ve placed the light, go to the Object Info palette. 
Let’s make some changes. Notice that the light is already set 
up to cast shadows, but for this tutorial, let’s also select Soft 
Shadows, for a better rendering.

Next, let’s adjust the brightness. We’re putting a light in a very tall 
space, so we should make the light brighter. For now, let’s make 
this 150%.

And finally, let’s adjust the Distance Falloff setting. This setting 
controls the rate at which the light falls off with distance. Click on 
the Dist Fall drop-down box, and take a look at the options. There 
are three options here; the first has no distance falloff at all, the 
second is called Smooth, and causes the light to fall off linearly, 
and the third selection, called Realistic, causes the light to fall off 
in a much more accurate, realistic fashion. Let’s choose Realistic.

Finally, let’s raise the light to the correct height. Down at the 
bottom of the Object Info palette, there is a Z data field. 
Remember that Z refers to height or elevation, so click in the data 
field and enter 5000mm. 

Switch to a Front view, and verify that the light is indeed at that 
height, right under the ceiling.

Now let’s take a look and see how much light is in the scene now. 

Switch to Saved View 1, and render with Realistic Interior Fast.  

Notice that the amount of light here is really not sufficient to 
illuminate the entire room; this light’s brightness is equivalent to 
about a 150-watt incandescent bulb. So to add more light to the 
room, we can either increase this light’s strength, or add more 
lights to the room. For this tutorial, we will add more lights.

Switch to Top/Plan View, and make sure the light is selected. And 
now press the Option key and drag down an extra light, to about 
here. 

Switch back to Saved View 1 and render with Realistic Interior 
Fast. You can see that there’s quite a bit more light now, but even 
more light is still needed.
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Before going on, notice that the rendering is displaying these 
little icons of light objects. These are useful to see when you’re 
working in wireframe view, but not so desirable in a rendering. 
We can make them invisible in the renderings by doing this: go to 
the Vectorworks Preferences...click on the Display tab at the 
top, and then on the right side, next to Display Light Objects, 
click on the drop-down box and select Only in Wireframe. Then 
click OK. Now the scene will re-render, but without showing those 
light icons.

So now we’ll add more lights in the room. To make this easier, 
and also to increase the visual realism of the scene, the file 
includes models of light fixtures, already placed under the 
ceiling, as you can see over here. There are ten of these models, 
distributed throughout the room. Switch to Top/Plan view for a 
second, and now you can see the fixtures. Let’s switch back. 
These light fixture models are symbols, actually, but they don’t 
contain any light objects in them, so our next task is to edit this 
symbol, and then add a light object. And once we’ve added a light 
object to the symbol, that light will automatically appear in each 
instance of that symbol in the room. It’s a way of increasing the 
number of lights in the room using a symbol, instead of adding 
ten individual lights one by one. 

First, let’s render in Wireframe. And now let’s delete the lights we 
added earlier, since we’re replacing them with the light fixtures 
we’re editing.  And now double-click on one of the light fixtures in 
order to edit the symbol. In the Edit Symbol dialog box, select 3D 
Component, and now we’re looking at a side view of the fixtures 
in the symbol. Let’s zoom in, to where we can see the model of 
the light bulb in the fixture.

Now let’s insert a light object. In the Visualization palette, click on 
the Light Tool, and then in the Tool Bar, select Point Light Mode. 
Now click in the drawing, roughly in the middle of the light bulb, 
here.

Let’s go to the Object Info palette, to make some adjustments. 
Select Soft Shadows. Change the Brightness to 150, just as we 
had it before, and then click on the Distance Falloff drop-down 
box and select Realistic.

One more thing to do. We need to make sure the light object is 
centered on the light fixture, so switch to Top/Plan view and then 
on the Fit to Objects button, in the View Bar, and we can see that 
the light is indeed centered in the model. 

Click on the Exit Symbol button, on the upper right side, and 
we’re back in the scene. Let’s switch to Saved View 2, for a wider 
view of the room.

Now render with Realistic Interior Fast.. It may take a little bit of 
time because darker scenes can sometimes take a bit longer to 
render.

Let’s recap for a minute. First we created a single light object, 
and placed it in the scene. Then we added another one, to add 
more light. And finally, we deleted those lights, and instead added 
a light object to a symbol of a light fixture that was already in the 
scene. Once we edited that one symbol, the light appeared in 
each instance of the symbol throughout the scene, so we added 
a great deal more light to the scene that way.
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For a better quality view, render with Realistic Interior Final. But 
just be aware the the rendering will take considerably longer than 
Realistic Interior Night Fast.

Before we finish we’ll do one more thing. Let’s add a couple of 
spot lights to illuminate the artwork on the walls. Switch to Top/
Plan view, first. Now go to the Visualization palette, click on the 
Light tool, and then up in the Tool bar, select the spot light mode.

Now we’ll place the light. Click once near the sofa, here, and then 
drag the cursor over to the artwork next to the wall, and click on 
the artwork. 

Now we’ve placed a spot light, and let’s make a few adjustments 
in the Object Info palette. Select Soft Shadows, and in the 
Distance Falloff drop-down box select Realistic. Give the light a 
brightness of 300%.

Now let’s adjust the height of this light. In the Z data field, enter 
5000 mm. And in the Look To data field, enter 1000mm. This 
means the light is right under the ceiling, and it’s pointing to a 
target that is at 1000mm above the floor.  Now switch to Saved 
View 3 and render with Realistic Interior Fast, to see the light in 
action.

Now add one more spot light on the second artwork. Switch to 
Top/Plan view, and duplicate the first spot light by pressing the 
Option key and dragging the duplicate to the side. 

In the Object Info palette, go down to the Pan data field, and next 
to the existing figure, enter -90, and then press tab. This will 
rotate the fixture to the right. Now drag the fixture so it aligns with 
the second artwork, here, and then switch to Saved View 2. 

Render with Realistic Interior Fast, to see the result.

Let me mention a couple of things about spot lights. Let me 
switch here to wireframe for a minute...The spot light has a 
number of interactive controls that can make it easier to adjust for 
particular effects. For example, the spread and beam diagram, in 
the Object Info palette, lets you manually get ahold of the controls 
for the beam and the spread, and make adjustments visually. And 
the same with the pan and tilt controls at the bottom; you can 
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enter numbers manually, but you can also drag the sliders and 
then see the effects interactively; especially when rendering in 
OpenGL (depending on the file).

One other item. We’re using these lights in their simplified format, 
in keeping with the spirit of this Getting Started Guide. But these 
lights also have more capabilities and refinements, all of which 
are documented in the support documentation. For example, 
when you have a light selected, you can go to the Object Info 
palette and select Use Emitter, and this will allow you to select 
a brightness for the light based on real-life lighting data, using 
either Lumens or Candelas as the lighting unit. A 100-watt 
incandescent bulb, for example, emits around 1750 lumens, and 
this can be replicated using these controls.

Now these lights that we have worked with in the tutorial are 
just a couple of several different types of lights available. There 
are also linear lights, similar to neon or fluorescent in their light 
output, and there are area lights--similar to fluorescent ceiling 
fixtures, and there’s even a texture, called Glow, that can emit 
light and be incorporated into a light fixture. All of these are 
discussed in the support information available via help and other 
manuals, but at the core, these are all variations on the lights we 
created, and worked with in this exercise.

Interior Day Lighting
One of the joys of working with Renderworks is rendering interior 
scenes that are lit by the sun through openings or windows. The 
light comes in and bounces off the interior surfaces, and this 
results in subtle combinations of shades, shadows and colors. 
What’s even better is the ease with which this can be done. All 
that is needed is to place a Heliodon in the scene, adjust it for the 
best angle of light and then simply render.

Let’s take a look at the process. Open the file used in this 
exercise: building lobby day.vwx. It’s in plan view, and the first 
thing we’ll do is place a Heliodon. Click in the Visualization 
palette, and then select the Heliodon tool. Now click in the scene 
to place the Heliodon.

Now we’ll adjust the Heliodon’s settings for this exercise. Later 
we’ll take a look at modifying these settings for the best results.

With the Heliodon selected, we’ll go to the Object Info palette, 
and click on the Settings button. In the Settings dialog box, make 
the following changes.

For Region: USA

City: Bangor

Now click OK.

And then back in the Object Info palette, click on the Solar 
Animation button. In the Solar Animation dialog box, make 
sure Heliodon is selected, at top....and now make the following 
changes.

Day: 4

Month: 2

Hour: 1

Minutes: 30

Click OK.

Now we’re done making adjustments to the Heliodon for this 
tutorial, so let’s take a look and see how this scene will render. 
Go to Saved View 2, and then render in the Renderworks Style: 
Realistic Interior Fast.

Now that we have the basic rendering, there are a few things we 
can do to tweak the lighting for better results. First, let’s see if 
adjusting the position of the Heliodon will improve the lighting. 

Let’s render in OpenGL first, so that we can observe the position 
of the sunlight immediately. The speed of OpenGL rendering is 
important here. [render now]

By the way, if you’re not seeing shadows, you’ll need to 
arrange the OpenGL settings to display shadows. Go to: 
View>Rendering>OpenGL Options, and arrange the settings 
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as shown here (and these settings also control other features as 
well):

Detail: High

Use Textures: selected

Use Anti-aliasing: selected

Use shadows: selected

Quality: High

Click OK to finish.

Now let’s adjust the position of the Heliodon. The Heliodon object 
is still selected, so go to the Object Info palette and click on the 
Solar Animation button, at the bottom.

In the Solar Animation dialog box, move the Day and Hour 
sliders to adjust the position of the Heliodon, and of the shadows. 
Be aware that OpenGL does not display light bouncing between 
surfaces, so the image will appear darker than when rendered in 
a Renderworks Style.

Once you’ve found a suitable position for the Heliodon, click OK. 
And now render in Realistic Interior Fast.

There’s one more easy adjustment we can make, and that is 
changing the strength of the Heliodon’s light. In some cases with 
sunlit interiors, increasing the Heliodon’s brightness can make a 
significant difference in the quality of the lighting.

The Heliodon is still selected, so go to the Object Info palette, and 
in the Sun Brightness data field enter: 200, then hit the Tab key, 
or the return or enter keys. The scene is currently rendered, so it 
will re-render as soon as the keys are pressed. Then, as soon as 

the scene renders you’ll see the difference right away.

Here’s the scene with the Heliodon brightness at 100, and here it 
is with brightness at 200. 

The difference is even more pronounced when the scene is 
rendered with Realistic Interior Final, which increases the number 
of light bounces between adjacent surfaces.

So you can see that lighting an interior with the sun is a simple 
business with Renderworks. The key points are to have a 
Heliodon with the correct adjustments to bring light into the 
interior of the space, in such a way that light bounces around the 
surfaces inside the room. And don’t forget that shadows can add 
a great deal of interest to a scene as well.

And finally adjust the Heliodon’s brightness to improve the 
rendering, if that is necessary.
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